narkive is for sale. Interested?
Discussion:
Portaudio & Digidesign ASIO driver
(too old to reply)
Zabukowski
2011-02-19 20:03:33 UTC
Permalink
Hi :)

I've seen a few questions here and there about Portaudio and Digidesign ASIO driver problems.
Still, can't find a definitive answer about it (if there is any ?)

I've recently come to situation, where Pa_initialize on machine with Digidesign ASIO driver,
simply terminates my program. Program is otherwise working without any problems on many
configurations/soundcards etc.

Any news or solutions (other than blacklisting) about this issue ?

Thanks in advance !

Franci
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://music.columbia.edu/pipermail/portaudio/attachments/20110219/5e00c7e9/attachment-0001.html>
David Viens
2011-02-20 02:22:33 UTC
Permalink
Hi

This only happens AFAIK in when you run your portaudio app in debug.
yes, its a copy protection measure that kills any chance of running pro tools in debug mode.
(that extended to their ASIO drivers for some reason)
Post by Zabukowski
Hi :)
I've seen a few questions here and there about Portaudio and Digidesign
ASIO driver problems.
Still, can't find a definitive answer about it (if there is any ?)
I've recently come to situation, where Pa_initialize on machine with
Digidesign ASIO driver,
simply terminates my program. Program is otherwise working without any problems on many
configurations/soundcards etc.
Any news or solutions (other than blacklisting) about this issue ?
Thanks in advance !
Franci
<http://www.facebook.com/franci.zabukovec>
_______________________________________________
Portaudio mailing list
Portaudio at music.columbia.edu
http://music.columbia.edu/mailman/listinfo/portaudio
--
David Viens, Plogue Art et Technologie Inc.
Montreal. http://www.plogue.com
Robert Bielik
2011-02-20 06:10:23 UTC
Permalink
Post by David Viens
This only happens AFAIK in when you run your portaudio app in debug.
yes, its a copy protection measure that kills any chance of running pro tools in debug mode.
(that extended to their ASIO drivers for some reason)
http://www.codeproject.com/KB/security/AntiReverseEngineering.aspx#ThreadHiding

Regards,
/Rob
Zabukowski
2011-02-20 07:27:16 UTC
Permalink
User is running my app without any debugger - pa_initialize just exits (Windows 7 x64 / 32 bit app).
When I add ASIO Digidesign Driver to blacklist, it works !!!

There is check in Portaudio (pa_asio.cpp) which prevents loading driver when debugging is active.
But even if debugger is active, this check wouldn't terminate a program.
Hi Guys,
It seems that since the update of Protools 7, Digidesign has added an asio driver for its mbox.
Problem is, this driver make crashes Portaudio at the init level
and so far the only solution I have found is to add this one to the blacklisted list.
It currently crashes when calling
rc =
CoCreateInstance(lpdrv->clsid,0,CLSCTX_INPROC_SERVER,lpdrv->clsid,asiodrv);
in AsioDriverList::asioOpenDriver
If you want me to run some test, don't hesitate.
Regards,
--
Olivier Tristan
Ultimate Sound Bank
Thanks
Franci
----------------------------------------------
Hi

This only happens AFAIK in when you run your portaudio app in debug.
yes, its a copy protection measure that kills any chance of running pro tools in debug mode.
(that extended to their ASIO drivers for some reason)
Hi :)
I've seen a few questions here and there about Portaudio and Digidesign
ASIO driver problems.
Still, can't find a definitive answer about it (if there is any ?)
I've recently come to situation, where Pa_initialize on machine with
Digidesign ASIO driver,
simply terminates my program. Program is otherwise working without any problems on many
configurations/soundcards etc.
Any news or solutions (other than blacklisting) about this issue ?
Thanks in advance !
Franci
<http://www.facebook.com/franci.zabukovec>
_______________________________________________
Portaudio mailing list
Portaudio at music.columbia.edu
http://music.columbia.edu/mailman/listinfo/portaudio
--
David Viens, Plogue Art et Technologie Inc.
Montreal. http://www.plogue.com
_______________________________________________
Portaudio mailing list
Portaudio at music.columbia.edu
http://music.columbia.edu/mailman/listinfo/portaudio

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://music.columbia.edu/pipermail/portaudio/attachments/20110220/e14026c0/attachment.html>
Loading...